Thursday, April 24th 2014, 7:48am UTC+2

You are not logged in.

  • Login

Dear visitor, you are currently not logged in. Login or Register as a new user .

reno

Beginner

  • "reno" started this thread

Posts: 13

Location: Paris, France

  • Send private message

1

Wednesday, August 19th 2009, 11:14pm

MacOS 10.6 "Snow Leopard" support

Hello,

I'm an early (too early :rolleyes: ) adopter of Snow Leopard, and here's my experience with OS 3.0.5 so far.
I have already discussed this privately with Marc and Access support, I'm posting this here so that people know what to expect when they consider upgrading to 10.6 in a few weeks.

Summary : 10.6 is not supported with TI OS 3.0.5, but I was still able to use VC, and the Virus TI as my audio interface in Logic 9 almost normally !

There are limitations however : apparently you should have the Virus plugged-in at system startup to have it recognized.
And most importantly, it seems impossible to use the Virus as your audio interface with applications that don't allow you to pick an audio device, but just use the system default (e.g. iTunes).
The reason for this, is that the Virus isn't listed as an audio interface in the Audio/Midi Setup App, except if you force that app to run in 32-bit mode (see its properties in Finder). And even then, you still can't select it as your default output/input.

I should mention that I'm running Snow Leopard in 32-bit kernel mode (go to the "software" section in the system profiler app to check whether that's your case).
So it's not really that 3.0.5 is already 64-bit ready, it's just that 10.6 in 32-bit mode "tolerates" some 32-bit components of drivers to work (VC, since Logic 9 is 32-bit anyway, the CoreMidi and part of the CoreAudio driver)

In short : although it's not supported, in my own experience if you have another audio interface that is working under 10.6 already, and you are not using a 64-bit host sequencer (are there any on the Mac anyway ? Cubase ?), and you're ok with your Snow Leopard kernel running in 32-bit mode, then you can upgrade to 10.6 and use your TI with VC in the current 3.0.5 release.
Of course, this is not recommended by Access and is my own experience, YMMV ...

Zork

Beginner

  • "Zork" has been banned

Posts: 6

Location: Hamburg

  • Send private message

2

Thursday, August 20th 2009, 12:05am

i use a mac and cubase 5..will be curious if everything works like on leopard..

cheers

gipe

Beginner

Posts: 10

Location: Europe

  • Send private message

3

Friday, August 21st 2009, 8:36am

I use both logic 9 and Cubase 5, i will test it when Leopard Snow will be in the final release.

reno

Beginner

  • "reno" started this thread

Posts: 13

Location: Paris, France

  • Send private message

4

Saturday, August 22nd 2009, 5:47pm

Since going back to Leopard is too much of a pain, I'm still experimenting with workarounds while waiting for 10.6 support :

I've found that JackOSX can help with apps like VLC that allow you to pick your audio interface, but don't directly work with the Virus this way for some reason...

Put JackOSX in between : install it, pick the Virus TI CoreAudio driver in the Jack preferences, then pick JackRouter as the audio device in VLC, and here goes !

JackOSX 0.82 has itself the exact same issue as the Virus TI driver : it's not yet Snow Leopard aware, so you can't set it as the default/system audio device yet.
But it's Open Source software, so I'm currently trying to build a 64-bit version of the JackRouter component...

I hope Access beats me to it with proper 10.6/64-bit support in the TI drivers, though ;)