Setup virus ti desktop (1st series) with logic pro X and novation sl MK II problem

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Setup virus ti desktop (1st series) with logic pro X and novation sl MK II problem

      Hello everyone,
      I use logic pro x, with a NI komplete soundcard, and a novation SL mk II as midi keyboard.
      I have just purchased an access virus ti keyboard version, and the problem is the following:
      I've installed the virus, started to test with its vsti plugin, presets, everything goes fine,
      but;If i turn on the the sl mk II, the keyboard function of the virus is just disappears, and the notes can can be triggered only on the sl mk II.
      If i start logic with both virus and sl mkII switched on, than both triggers all the rec.enabled tracks, so the virus also itself.
      How can i set up, as general the controller and the virus in logic x, to get the behaviour, that virus's own keyboard triggers only virus, and the sl mk II does it for everything else?
      Thx in advance
    • does the midi device for TI disappear? (use the audio/midi app in mac osx)

      I find that if the mac has been to sleep, and then I power up the TI, then initially the TI midi device will be present, but if i power up another USB device the TI midi device will disappear.
      (it appears when the USB devices have change, and so are 'refreshed' the TI midi driver dies)
      this can be fixed either by power cycling the TI, or rescan midi devices.

      this was not fixed by 5.1.0 (was present before), and Ive been told by Access, they don't support 'sleep' mode, so basically they are not investigating the issue :(
    • thetechnobear schrieb:

      this was not fixed by 5.1.0 (was present before), and Ive been told by Access, they don't support 'sleep' mode, so basically they are not investigating the issue

      if you power stuff on or off while the computer is sleeping, all sorts of things can happen. it's just something that one should not do. at the same time, we've fixed something sleep mode related in 5.1 and, even though i cannot remember what you're referring to exactly, i think the sleep mode issue i was talking about is fixed. nevertheless, feel free to remind me :)
      marc
      The Virus on Facebook: facebook.com/accessvirus
    • the issue is still in 5.1.0

      sequence (assuming mac is on, and virus working fine)
      a) turn virus off
      b) put mac to sleep, (wait until it really is a sleeping, can take 10-15 seconds)
      c) wake mac
      d) turn on virus
      at this point, virus works fine, midi is connected etc - all good
      e) connect another USB device
      f) start an app that queries available usb devices (I'm not 100% sure if this step is necessary,but i think so)
      bang, Virus Midi device disappears.

      Ive got a few USB devices that this happens with, Leap Motion, Eigenharp Pico, Keith McMillan soft step,
      (and i think Push as well, need to double check that one)

      the 'workaround' is to ensure that the virus is turned on last, so never connect a new USB device when the virus is on. this is a bit of a pain sometimes as you don't always know what you will be using.
      if the virus midi device disappears you can bring it back, by doing a midi scan BUT, this can cause problems with quite a few applications, they get confused by the Virus midi device disappearing,
      (e.g. Ableton, you end up with Virus Synth , and Virus Synth #2, the former doesn't work, so you need to alter your project to the later… but then can't save it, as next time it will be Virus Synth - arghh!)

      Ive checked in the console/logs, and there are no errors reported…

      also, I got a new iMac at the end of last year, and the same thing happens with both old and new mac.

      its not a big issue, but it would be great to see if you can replicate, and therefore get the devs to take a quick look.
    • ok, update...
      so, the other day when i installed 5.1.0 i got the problem as described above...
      but today, I decided to test the Push to see if it made the device disappear after sleep, and it didn't.
      so i then tried my other devices... and all was OK!!!

      anyway decided to power down the TI, and try one last time...
      TI didn't initialise USB midi driver at all, no USB on TI display, midi device in audio/midi app shows disconnected.
      checked the console and I can see:

      Quellcode

      1. 23/10/14 20:14:46,000 kernel[0]: USBF: 170713.724 The IOUSBFamily is having trouble enumerating a USB device that has been plugged in. It will keep retrying. (Port 1 of Hub at 0x14000000)
      2. 23/10/14 20:14:51,000 kernel[0]: USBF: 170718.152 The IOUSBFamily was not able to enumerate a device.


      and further up...

      Quellcode

      1. 23/10/14 20:09:22,000 kernel[0]: DeviceRequest returns E00002ED
      2. 23/10/14 20:09:22,000 kernel[0]: DeviceRequest returns E00002ED
      3. 23/10/14 20:09:22,000 kernel[0]: start PGKernelDeviceVirus v3.3.0.b.4 failed. reason:m_pDevice->onServiceStart() failed


      doesn't matter if I restart TI, or reinsert USB cable, same issue.

      so for some reason, TI will now not initialise (its been working fine on 5.1.0 for days), so adding/removing usb devices must have some how provoked this
      ... I'm going to try rebooting, see if this 'fixes' it.
      UPDATE: ok, so rebooting did NOT fix the issue TI still refused to connect, I then did a 'soft' reset (arp edit, power on) - still nothing. Rescan Midi - still nothing.
      I then tried VCC. this could not see TI, so I put it into USB UPDATE MODE, and magically, midi driver loaded, and everything was back to normal!

      Unfortunately, for the above, Ive no real idea how this occurred... other than plugging/unplugging usb devices, but thats not going to be 'reproducible',
      ... will let you know if it happens again (unlikely i think), but at least I know how to fix it, if it does :)

      Sleep issue, Ok, I'll presume it was gremlins after the 5.1.0 install, and was fixed in 5.1.0 (thanks Access :) ) ... so, I'll stop 'working around it' and let you know if i see it again.



      Dieser Beitrag wurde bereits 2 mal editiert, zuletzt von thetechnobear ()

    • thetechnobear - there is something we have seen over the years. not often, not often enough to be concerned but the USB chip itself in the Virus can crash. and all you can do in this moment is to remove the power cord, rebooting will not help.
      as it turns out, we cannot do anything about it, it is the chip that crashes, nothing we even produce ourselves or can influence. the good news though is that we have never seen this unless some aspect of the Usb chain has changed while things were up and working good. so when playing a set live (without changing equipment and such) it won't be an issue.
      best, marc
      The Virus on Facebook: facebook.com/accessvirus
    • thanks, yeah, id guessed it was just a rare oddity… its the first time I've seen it.
      so is just removing the power cord enough? ( i didn't need to go to usb update mode?)

      btw, another oddity I've noticed (again no real issue)
      if i disconnect power from the TI, while it is turned on, when i reconnect and turn the TI, the LCD display is corrupted. (i used to just turn off at the power supply)
      so instead before I turn the power off, I always now put the TI in 'standby', then power off.
      no real problem, i guess its some kind of power spike issue, but wondered if its common.
      (its a TI mk1)
    • ok, bad (semi) news...

      the sleep issues does still seem to exist in some form, I turned on my virus to do some stuff, was happily playing away - then about 5 minutes i decided I needed my Push so turned it on...
      poof, Virus Midi device disappeared, so now I have to restart ableton, as its now showing up as Virus Synth #2. (after i do a midi rescan)

      can someone else test this, I'm a bit surprised I seem to see it with many (all?) of my USB devices, yet its not a known issue.