Using Virus TI with Large Logic Template - Large Process Buffer Range

  • Hello Access Forum,


    Wondering if anyone out there might have some input for my new template. I work in film and TV and my Logic template is around 500 tracks. Some more details- OS10.6.8, Logic 9.1.4 running at 64bit, 2.66ghz Quad, 16gb RAM. Because of the size of this template I must set my process buffer range in Logic to "Large." I understand that this is not recommended for the Virus (and I have encountered some weirdness) but this is a MUST. I am not able to operate smoothly with a smaller process buffer.


    That being said, does anyone have any thoughts / experience on this subject?


    Many thanks.


    best
    Joe Trapanese

  • Hi Joe,


    I have a pretty large Logic template as well. Although I'm not maxing out my system (yet,) I did try to set Logic's processor buffer to Medium and Large just to see if that would, by some miracle, help resolve the many issues I have been experiencing trying to run Virus Control in Logic. Unfortunately, setting the buffer range to anything but Small just made these problems worse.


    However, I highly doubt setting the buffer size to Medium or Large would cause any damage. So if you can get it to work most of the time, I would just leave the buffer set to Large. It sounds like you don't really have a choice. :-)


    The other (unattractive) option is to run the Virus via MIDI only and just do everything from the front panel of the Virus. This works flawlessly for me.

    Synths: D-550, EX-8000, Matrix-1000, Microwave, Microwave XT, MKS-50, MKS-80, Nord Rack 2, Nord Rack 3, Pro One, Prophet '08 Rack, Pulse, Pulse 2, Shruthi, TX7, Virus kb, XV-5080, Maschine
    Computer: Core i7-970 3.20 GHz Hexacore, ASUS P6X58-E PRO, ATI FirePro 2460 quad head, RME RayDAT w/4x Alesis AI3, 2x MOTU MIDI Express 128, Cubase 7.5

  • However, I highly doubt setting the buffer size to Medium or Large would cause any damage. So if you can get it to work most of the time, I would just leave the buffer set to Large. It sounds like you don't really have a choice. :-)


    "large" does not work, "medium" only if you don't really use the virus. it was like this from day one and will not change unless apple changes something in logic (though i'm not sure if they can change it to make it work). the virus cannot handle buffer sizes of 1024 and more, depending on what you're doing, 512 can be your limit as well. this is stated very clearly in the quickstart guide, the virus control guide and the setup guide.


    best, marc

  • To possibly solve your buffer "small" "medium" or "large" setting problem in Logic with Virus-TI, use an additional Mac or 2 or more with the same OSx system; connect them all to your main Mac, and launch X-grid on each as instructed by Apple or Mac Guru forum. This puts the additional Mac's into slave mode and distributes the work load. Also enable Logic Nodes.
    :thumbup: