Ableton Live Midi Setup + Out of Sync / Clicks & Pops Problems

  • Hi,
    I love my Virus TI2, but I'm having problems from the day it arrived at home, so now I decided to ask for some help.


    I have a MacBook Pro 13" 2010.


    First - MIDI SETUP IN ABLETON LIVE:


    I know, there is a Setup Guide for Sequencers, but there isn't a section where I can see how to setup the midi preferences in Live 8.


    There are 3 buttons for Input and 3 Buttons for Output, these buttons are Track - Sync - Remote.
    In my Setup I just have the "Track" ON for Input and Output, is that correct or I need to set it up in a different way?
    There are things to adjust in the Midi Clock Sync Delay / Midi Clock Type / Port Type configuration area?


    This is an example image of the Midi Setup in Live (just downloaded from Google Images):


    [Blocked Image: ]



    Second - OUT OF SYNC / CLICK & POPS:


    My soundcard is a Presonus Firestudio Mobile (just bought), in Ableton Live I have a 256 Buffer Size, my Virus TI2 is connected through USB to a power-packed HUB (I know, it's not recommended but It's my only choice) that's shared with just an External Hard Drive and I use the Virus TI Software as an Audio Unit on Mac OSX - I updated the software to the latest version.


    Using the "Live" button in the Software doesn't change anything, rather sometimes it's worse.
    I tried other Soundcards and I have same problems.
    My CPU Meter isn't high (I always reach 60 / 70% max)


    Thing is, I just want to know, is that possible that's because I'm using USB with a HUB, or just because using it with USB causes these problems?
    Is that possible that if I use MIDI cables and Audio Outputs instead of the USB cable I solve all these problems?



    I just want a stable setup.. :(
    I hope you can help me with that,
    thanks.

  • Marc, I appreciate your help, but as I said in my first post:


    Quote

    I know, there is a Setup Guide for Sequencers, but there isn't a section where I can see how to setup the midi preferences in Live 8.


    The Ableton Live setup guide is for Live 5, now Live is at version 8, and there is a Midi Setup where you can choose to activate or not MIDI Track / Sync / Remote both for "Virus TI MIDI" and "Virus TI Synth", I already read the manuals, and I can't find something useful about that.


    I'm just asking if someone in this forum knows the right way to set it up without having any problem.


    BTW I'll try to ask it on the Ableton forum too.


    Thanks

  • Are you planning to use the VST driver? In this case there is no need to prepare a MIDI configuration for it, as the VST engine handles all the routing from the appropriate track(s).



    If not, then you should detach the USB plug and let the Virus work as standalone with input from your soundcard MIDI out, and configure the MIDI out for your soundcard.



    The other thing is that a hard drive is a bad neighbour, when placed on the same hub as you are... It has huge bursts of information enough to put sticks in the wheels of any other demanding/real-time device.



    A good differential diagnosis would be to connect monitors to the audio outs, direct the current patch to go through them, play the the patch from Ableton and listen for any crackle and pops.



    Good luck.

  • You totally helped me!
    I disabled all the MIDI settings in Live, and I connected the Virus directly on my Mac, switching the Hub with the HD on another Hub, now everything seems to be nice!