USB Issues & Mavericks

  • Sorry to start a fresh thread.


    As I posted in the other thread, I'm having problems with getting the VC to work with a late-2013 MBP. I'm running OS 5.0.7 on Mavericks. I've used the Virus for over 6 years and am aware of most of the USB and sync problems.


    I initially thought, the problem could be due to the USB Bus power. To confirm, VC does not open at all, when connected to the ports on my non-thunderbolt Apple Display. I finally plugged it straight into the MBP.


    Now, while VC starts up with the direct connection, I can barely play the keyboard. It works fine when I use another controller or on-screen keyboards to play it. But, on the Virus itself, notes get stuck every 3 or 4 strikes (only happens when connected via VC). Only other device connected is the Interface and a keyboard. I also, strangely always need to switch Local to ON for it to even function, while using VC.



    Solutions I've tried:


    - Restarting the computer
    - Restarting the Virus (un-plug method)


    - Re-installing the software
    - Different USB Cables, USB ports


    My last option is to pick up a USB hub dedicated to the Virus. I'm not sure if this would work. For me, previously, it sometimes worked having a hub and at other times I had to connect it directly.


    Access, is this a Mavericks only issue? I can't seem to figure out how to fix this. The laptop has 2 USB ports. I at least need to connect 4 devices (Interface, Maschine, Controller and the Virus). Would hate it, if the after picking up the Hub, I get the Audio/MIDI driver fail issue.


    Thank you.

  • Hope this is fixed ASAP then. They should have put a warning on the site for 5.0.7. -.- Meh


    Does 5.0.3 work with Mavericks?


    i've tried a couple of times to replicate this one but so far i've failed. i'm curious why it happens after a couple of seconds for you and i can let the TI keyboard run over night and it is fine the next morning. could you please work on this one with support by email?
    thanks, marc

  • Marc , there are a few that have had this 48khz issue here, and its been resolved by switching to 44khz... one filed a support report only a few days ago.
    for my part, I also recorded a video to highlight the problem and gave a lot of details on my setup etc (on the mavericks thread).


    I'm surprised you are not able to replicate, as it happens for quite a few people here, and happens as soon as i switch to 48khz reliably.
    (btw, its not about leaving the TI idle, you have to be sending midi)


    perhaps if you raised a thread, asking people to try, and reporting there hardware/software setup, you may be able to get more data...


    If you do so, then I would be willing to invest some time helping e.g. trying on my other iMac which also has 10.9 on it...


    EDIT: ok, to show I really want to get this working I'm trying a few things for you...
    a) Ive tried on 10.9.2, the issue persists
    b) Ive tried in both Ableton 9.1.1 and Max 6, both have same issue
    c) Ive tried built in audio , my saffire audio and the virus TI (both bit and core audio ) - all have same issue at 48khz


    I'm now trying my other iMac, which is also on 10.9/5.0.7... Im just waiting for it to download the banks from the virus, which takes along time (about 15 minutes I think last time!)
    ... this will test it wilth built-in audio and virus audio @ 48khz, using Reaper (the only thing I have installed on it)

  • ok, so took quite some time to get the other iMac setup... but done.


    exactly the same issue.... 44khz no issue, 48khz, create VST - bang midi has stuck notes..


    this was using reaper on a completely different mac.


    so...
    it does it in Max, Ableton Live 9, Reaper
    it does it on a Late 2013 iMac, and an Early 2008 iMac
    it does it with USB hub or not - with no other usb devices connected
    it does it with audio interface (focusrite saffphire pro 1), build it audio and both Virus TI audio outputs... (note: second iMac doesn't even have AI connected at all, so only has built in audio and Virus audio)
    it does it with different bus cables.
    I've tried resetting virus multiple times
    Ive already reinstalled the 5.0.7 twice on the virus (as well as downgrading to 5.0.3)


    only does it with 48khz, using 10.9, 5.0.7


    oh, one thing, last time when i downgraded it back to 5.0.3 and tested it on my macbook pro with 10.8/5.0.3 i can report 48khz worked absolutely fine.



    completely different computers, daws, audio interfaces,
    completely different people experiencing it...


    I really cannot think of anything else to try....


    thoughts?


    P.S ive now sent an email to support, with details so that it can be tracked.

  • I too am working with support to understand the 'Notes Stuck' issue. I was advised to try 5.0.8. Issue still exists.


    While, I can't seem to replicate it. I did briefly run into the issue technobear has been mentioning, regarding the 48 & 44.1KHz. VC was not open. I was trying to use the Virus to play other synths.


    The issue was worse than the one I mentioned as the notes are just continuously stuck and 'Panic' didn't seem to work. Switching to Reaper and playing around with Project Settings to swap sample rate, I got it eventually to play fine at 48KHz within Reaper. After that, it seemed fine even with Logic X at 44.1 and 48 and I can't re-create the issue yet. But, it's definitely there.


    I've tried 2 computers here as well.

  • is there any difference between 5.0.7 and 5.0.8?
    change log is identical... is it just an official and includes windows as well?


    Given issues Ive faced upgrading in the past, I really don't want to do it, unless there are known issues fixed.


    @Splaat, I also emailed support... re the 48khz issue and my tests, they said they have received other similar reports, some of which are fixed by using 44khz and some which are not.... they are not able to reproduce. they have sent the reports to development to aid diagnosing.


    Hopefully they are actively working on it, its a pain not being able to use 48khz, but sounds like I'm lucky to have a working solution at all unlike you.


    As i say, I only got the issue when VC was run... I then had to use the audio midi app to rescan the driver to fix it.
    (this reloads the driver, and is worth trying)
    Ive never had an issue except when VC was run (and in 48khz)


    I assume you are doing these tests, just with the virus plugged in (nothing else)... are you using an audio interface... if so might be worth testing without it.


    and with my later 2013 iMac , with 5.0.3 (10.8) i had to use a hub, though this fixed in 5.07 so i don't have to..


    good luck with resolving your issue.

  • I was advised by Jorg from Tech Support to give 5.0.8 a shot.


    I briefly had the note stuck issue, while VC was off. For me, without VC, everything works as it should. I haven't tested 5.0.8 further.


    I'm running this via an RME UFX.


    I've always had the hub/no-hub issue over the past 6 years. It comes and goes. : /


    Would be great to have VC functionality back.

  • With each update I dream that my snow will finally work the way it was marketed. The TI software is still a nightmare. Please give us a simple patch library/editor that runs as a vst plugin so we can move on.

  • I kind of sadly agree :( As much as I love using it, the Virus is spending more and more time stacked away. It's also one of the only synth I held on to.


    Only other option, I get used to running it stand-alone.

  • I kind of sadly agree :( As much as I love using it, the Virus is spending more and more time stacked away. It's also one of the only synth I held on to.


    Only other option, I get used to running it stand-alone.

    I know what you mean, i've updated, installed, re-installed, flashed the ROM more times than a Prostitute drops her knickers! I have 16 hardware synths, many USB and none of them have had the problems i've had with the Virus Ti. One day it will work for a few hours and the hope builds in me, then it will mess up and I end up doing a Sherlock Holmes on it for hours. What would make me happy and keep me quiet is to give me VC over midi cables, use as a plug in in Logic, but nothing to do with USB/Audio. That's it...nothing more. Total Integration has become Totally Irritating.