SNOW no longer usable as an interface after 5.0.8 MBPr Mavericks

  • After updating to 5.0.8 I'm no longer able to use my Snow as an interface. Attempting to record my guitar through the unit produces an output that is a hot digitally distorted mess. I tried it with Abelton, Logic and Reaper with the same results in each. The previous version 5.0.5 or .7 i believe, was working albeit flakily. That version is no longer available for download and I deleted the install.

    Any help or assistance? Please...

    Mavericks 10.9.2. Late 2013 MBPr.

  • In case anyone is having the same issue, here is the solution I found. I 1st uninstalled the new version. I found the beta 5.0.7 and installed it. This version gives you as an option ACCESS VIRUS (BIT ACCURATE) as audio input device. Choosing this passes clean audio. Choosing ACCESS VIRUS (CORE AUDIO) produces the same ugly distortion. 5.0.8 does not give you the BIT ACCURATE option. I have no idea what the difference is or why you wouldn't what your bits to be accurate, but this worked for me. The CORE AUDIO on output works but choosing BIT ACCURATE on output reduces overall latency by 3ms. Still quite high at 14.5ms at 128 buffer setting. 128 is as low as it will allow you to set it under BIT ACCURATE. CORE AUDIO allows lower buffer settings but are useless because anything below 128 produces the same ugly distortion sound.


    I just discovered the BIT ACCURATE option doesn't show up in Logic, only Abelton for some reason. So for now I can use my Snow as an interface in Abelton but not in Logic.

  • my ti desktop works fine with both "bit accurate" and "core audio" options ^^
    BUT whats the difference between two options? ?( i couldnt seem to find any explanation on the web since it only appeared in 5.0.8 and that's fairly new