Midi Driver Failed/no Audio Over Usb

  • Dear fellow Virus TI2 users,

    I have recently been experiencing a problem that I am struggling to work out even with the help of Access Support..

    My problem in brief:
    when I load my virus plugin software in logic it comes up with the message ... \'MIDI driver failed - the midi driver failed to start or is not properly installed. this can happen if you have too many USB devices connected. Also try installing the software again\'

    I have tried removing all other usb devices AND re installing the software (also have tried changing buffer size within logic and processing speed etc, giving logic a reboot every time).... still have the same issue... I know the Virus is USB hungry but even when I remove EVERYTHING I have the same issue.

    I have just upgraded my computer: 4.29 GHz Intel Quad Core i7 16 GB 1600 MHz DDR3 NVIDIA GeForce GTX 770 2048 MB Software: OS X Mavericks 10.9.2 Virus software: (which I have re-installed a few times to make sure)
    I am using Logic 9 - Version 9.1.8 The motherboard I have (GIGABYTE 787X-UD7) supports 8 USB 3.0 ports and 2x thunderbolt ports.. Surely this machine should satisfy the needs of the Ti2.

    Other heavy duty synth plugins seem to work fine ie. Omnisphere

    I NEVER had this problem while i was using my previous set up: early 2008 iMac 2.8 Ghz Intel duo core also running mavericks 10.9.2 I\'ve been using my Virus Ti2 for nearly everything for the past 2-3 years and it has become a integral part of my sound. Its really slowing down my workflow while not having it fully functional! Desperate help needed!!

    support told me this :

    Dear Joe,
    Thank you for your email. In this case I recommend to remove the entire TI OS suite from this Mac with the help of the Access uninstaller which you will find here:


    Additionally please remove the Virus Midi driver under

    [macintosh hd]/[library]/[audio]/[midi drivers]

    Whenever this has happened, please shut down the Mac, wait a few seconds and then restart the computer again. Next repair the disk permissions with the help of the "disk utility" program which you will find under


    and then install the very latest OS once again on the Mac and the TI and see if this helps. To install the TI OS again on the TI hardware, please unplug the power from your Virus TI and remove any other cable going from/to the TI. Wait approximately 30-60 seconds. While plugging back in the power only, hold down the EXIT button. This will force the unit into USB UPDATE MODE. Next try again to load in the very latest OS and check if this helps.

    I have spent today following these steps above...

    I completely unintalled virus software + midi drivers
    repaired my disk permissions,
    reinstalled latest available Virus TI2 software suite.

    When I first re booted and checked if it had worked it gave me the same warning message -
    ‘G-Raid device detected on the same USB Hub.. please re configure USB set up and rescan..’

    When I removed the device in question, and re launched the TI2 software suite, I managed to get passed the MIDI driver failed message, and I thought I was getting somewhere…. However now NO AUDIO OVER USB was getting to logic from the TI OS!

    I can see MIDI is triggering the virus because the level meter under my first patch on the Virus TI2 lights up when I press my keyboard…. yet in logic I am receiving NO audio over USB whatsoever.

    I mention that because I have then tried plugging analogue outputs 1/2 on virus into my sound card and bang, audio returns, exept its frequently with problems such as stuck notes/latent response….. MIDI is travelling to the virus TI2 over USB , but audio is not returning….

    - I have tried changing some settings on the TI2 like sample rate 44.1-48kHz .. no difference, clock source internal/auto.. no difference.

    My problem still persists, now its a case of - RANDOMLY unplugging and plugging my keyboard USB a few times, unplugging and plugging my virus USB, only sometimes (rarely) will the virus software will load..currently very..very.. unreliable.....
    Even when it does load after 20 attempts, again no audio over USB, only analogue audio which, like I mentioned, has problems all over the place i.e. timing issues + artefacts… what shall I do !?!?

    Does anyone have any further suggestions?? ;(

  • Is your machine an Apple product or a Hackintosh? (seems 'unusual' for a mac owner to start talking about motherboards)
    ... if the latter, good luck, lots of people get into problems with these, due to issues like incompatible drivers for certain components, and mixing this with something like a Virus TI which is known to be 'sensitive' to usb is 'asking for trouble'
    (even later iMacs have been having issues)

    its not so much the Virus TI is hungry for USB bandwidth, its just its picky about working on hubs and different usb versions. etc.

    the main advice is , remove all other usb devices, try in every port one by one, if that doesnt work, get a usb hub (2.0) and plug it into that (again with no other devices attached)
    if your lucky to get it working, then keep it in that port, and add (one by one) your other devices checking it doesnt cause an issue. (and use the system profiler to keep the other devices off the same hub (internal ))

    Do the sound devices show up in the Audio Midi setup? (both of them core audio and bit accurate)
    Does the Virus work as a soundcard? I would assume not.

    Sound to me like the audio drivers aren't working, I suppose there are no errors reported in the console?

    as for analogue outputs, what you are describing sounds like you still have an issue with the midi drivers... i,e the virus is not getting them (stuck notes), or getting them very slowly (latency)

    these may not help, but might help isolate the problem a bit:
    - If it a keyboard, can you get audio back ok without midi?
    - If you have a midi hub, perhaps gets some midi cables and check to see if you can get it running that way.
    - Tried another DAW?

    Unfortunately, Ive noticed that the Virus uninstall does not uninstall everything properly (I tried to roll back to 5.0.3 from 5.0.7 and it completely failed to do the uninstall/install and work).
    I think access are going to have to help you get the thing fully uninstalled (including settings audio and midi drivers), and reinstalled.. Id also be tempted to reinstall OSX

    Sorry, can't help, it sounds like a faulty driver somewhere -

  • Hi,

    Firstly, thanks for your time and quick response,

    I am indeed an apple used that has upgraded to a Hackintosh looking for a more powerful machine to run my projects... I really hope this machine can work with my virus...its basically the only synth I use.. I built this machine ONLY for the use and abuse of my virus... would be the biggest kick in the balls if it doesn't work..

    I have tried a few of the things you outlined,

    Firstly I removed all usb devices and tried all the ports individually.. same issue,
    I have a Belkin USB 2.0 4-Port Clip Hub, again, plug the virus into that, and then that into, again, every port.. same issue.

    Weirdly, both Bit accurate and Core audio devices DO show up in the audio/MIDI set up, and the analogue outputs surprisingly DO WORK! (so audio must somehow be streaming down the USB to the virus...)

    However when I launch the TI plugin software, same message 'MIDI Driver Failed'

    I have ensured to reinstall the software correctly, and I have made sure to remove the MIDI drivers from the user/HD library->audio->midi drivers before reinstalling. Still encountering the same message.

    Do I really have to reinstall OSX next? ;.;


  • when you say the analogue outputs worked... was this via the midi driver i.e. via Virus Synth , or via the TI keyboard / external midi cable?
    did you trying using the Virus as a soundcard?
    does the Virus midi device show up in the audio midi setup program? (try rescan if its not there immediately)

    what I would be trying to work out is:
    - is the Virus usb midi driver working or not (Virus Synth) ? - independent of the virus control VST/AUI, (feedback sound via analog into your soundcard/ use headphones)
    - is the virus usb audio driver working or not (core/bit accurate) ? - again independent of virus control. (send all audio from mac by using as your default sound device)
    - are the drivers reporting any errors?, this will be in the console.

    if there are no errors reported in the console (and I never found anything useful, even when my TI was acting up) then I cannot see you have much to go on.
    (there are some low-level usb debugging tools available, but you have to be very technical to get anything useful from them)

    The issue you face, is if you have tried all USB ports and a hub, (which I assume all work with other devices), then the issue can really only be an issue with the driver,
    given you have tried uninstalling the driver and reinstalling, the only thing i can think, is that its not uninstalled correctly, so rebuilding the machine is the only option I can think of.

    If you do rebuild the machine, what I would do is first try 10.8/5.0.3, see if the virus works with that... ( i had less problems on 10.8)
    if it does work, you can then choose to 'risk' upgrading to 10.9/5.0.8. (though I suspect if you get it going on 10.8 it probably will be ok for 10.9, but you never know)

    if it doesn't work, I wouldn't know what to try next... as theoretically it could be a mismatch with the motherboard/usb firmware and OSX, that somehow the virus is reacting too,
    but this seems less likely than just a corrupted install of the virus software.

    Im sure access will have some other ideas too ... or perhaps others here...

  • OK, somehow, I have managed to sort the problem out! I have currently got it to function completely normally again! (I really hope it stays this way!)

    I .have. spent. literally. 8. hours. today on this and thank f*** it hasn't been a waste of time!

    Technobear, thanks again for quick reply, I ran through all those things you suggested I try,

    firstly in answer to your questions:

    the TI2 DESKTOP analogue outputs were functioning normally, I could make the TI2 my sound card, and successfully play music through it.
    However, when I attempted to load the Access virus TI software (Audio Unit) on logic, it would always come up with the same message
    'MIDI DRIVER FAILED' too many usb devices blah blah blah

    The TI Hardware was showing up on Virus Control, and I tried reinstalling the OS quite a few times but with no success, same message kept appearing.
    So the MIDI Driver was apparently failing, but it felt like it was related to the USB connectivity, or some kind of USB setting in the BIOS

    Im not sure if the audio driver was the problem because I could get audio from the analogue outputs but not the USB audio.

    Was about to give up...

    I found someone posted this on a tonymac forum after complaining about a very similar case with his Virus TI:

    EDIT: Got it working. Go here: http://www.insanelymac.com/forum/top...5106610671068/ and DL the attached kexts

    The problem was that the provided IOUSBFamily doesn't support OHCI (USB 1.1 if i'm not mistaken)


    I personally have very little experience dealing with .kext files, but I had to give it a shot cause is was so bloody desperate.
    HD->System->Library->Extensions is where the .kext files are kept on MAC OSX (fyi anyone)
    After some research I downloaded a free program called kext utility which basically properly installs any .kext file you drop in the window

    I installed the IOUSBFamily.kext which you can download from that link.

    I also stumbled upon my other extensions folder by complete accident:
    HD-> Library -> Extensions

    and noticed there was a AccessVirusTI.kext in there.... hmmm there were only like 10 .kext files in that folder as opposed to my system-library-extensions there were 100s...

    I copied the AccessVirusTI.kext to my desktop and ran it through Kext Utility, which naturally installed it straight to system-library-extensions (where it WASN'T before)

    When i tried loading the software this time it started loading straight away, *excitement* however audio was still low level bitcrushy distortion.. but this was positive as I ran into that issue all the time with my virus and iMac, just usually needed to reboot ti, or computer and it would work..

    At this point I just moved my MOTU sound card to a different slot and its a MIRACLE BUT IT BLOODY WORKS WOO!

    Sorry for my lack of .kext knowledge but if you are suffering a similar issue id suggest looking into that!

  • Excellent news... congratulations :)

    funny this fix, sounds like the fix that polytec (who write the virus drivers) have suggested for the macbook retina issues
    see https://www.usb-audio.com/support.html


    - My device doesn't work correctly on a USB3.0 port, how can I make it work?
    Win: Make sure to install the latest USB host controller drivers for your motherboard chipset or USB controller card.
    Mac: Here's a way to downgrade to Mac OS X 10.7.3 USB2.0 support, reported to work on Mac OS X 10.7.4 and Mac OS X 10.8: http://xoneforum.allen-heath.c…etina-usb-30-issues-fixed

    Basically its downgrading the usb drivers to usb 2.0 drives from 10.7 which weren't giving problems before (apparently).

    Whats interesting, is that Im pretty sure these issues were fixed in either one of the 10.9 services packs or the newly released polytec drivers (i.e. 5.0.7+)

    So it seems odd that 10.9.2/5.0.8 still obviously has some issues with your system, perhaps due to a different USB firmware support on your motherboard.

    Oh well, glad it worked out for you!

  • Hi Marc,

    Sorry for the very late reply!
    I am indeed running a Hackintosh.

    I am also getting in touch because I my problem has come back once more.....

    Last week I made the fatal error of updating to from 10.9.1 -- 10.9.5..

    I know as a hackintosh user this is not a good idea, I must have accidentally clicked OK on the pop up in the top right during the madness of a studio session.. the next time I booted, I noticed the update installer began automatically on login, there was nothing I could do to stop it...

    Straight away I had kernel panics
    I had to boot in safe mode (-x) to get to my desktop, and thankfully my system was fine after a disc repair.... Everything except for my virus that is.

    I'm getting the same message as I was 6 months ago. In logic, the virus plugin software says

    'MIDI driver failed' the midi driver failed to start or is not properly installed. this can happen if you have too many USB devices connected. Also try installing the software again'

    My main assumption is that the latest OSX update has once again changed some kind of USB setting/driver.. or perhaps overwritten the IOUSBFAMILY.KEXT which I had previously downgraded... which is causing a mismatch with the virus ti2's requirements...

    I have tried reinstalling the same legacy iousbfamily.kext through the kext utility app which seemed to get it working last time... but with no success....

    I was very excited when I saw that had been released, I only installed it a few days ago because of my current issue, Thinking this would have solved these USB problems..

    Updating to has not helped me,

    Just the same as before, the virus appears as an optional sound card but the TI plugin still displays the 'MIDI driver failed' message.

    Is my only option to wipe my whole system and reinstall OSX 10.9.1 and follow my own steps which I did 6 months ago ?

    Do you have any advice for me for things to try otherwise?

    Desperate to get it working as I use it everyday.

    Look forward to hearing from you
    Many thanks,


  • joe -

    sorry, we can't help you with your issues unless you're using a real mac. i don't say this because you're running an illegal system. that's your decision. but the kernel panics and driver issues you face are likely happening, because the drivers do not work well with your hardware and that's where we have no inside or knowledge (this is apple's domain).
    the "MIDI Driver failed" indicates that the driver couldn't be loaded. this can happen due to a hardware/software issue but also due to missing bandwidth. you might want to look into the USB layout of your machine. if it makes extensive use of root hubs, make sure that the virus sits on a port which is not shared with other 12mbit USB devices. if you cannot guarantee that, put a USB2 hub in between. this trick has been explained a couple of times elsewhere on this forum.
    good luck, marc

  • chris, in my mail to you yesterday, i've mentioned that on your system, the midi driver / midi server does crash a lot. a driver cannot crash when it doesn't load beforehand.

    I am having the same problem and wasting a lot of time trying to fix it.


    Give me a link to click so I can download something and fix this.

  • Hi, Long time since I got back to music... I bought a Macbook pro retina 15 2014.

    I downloaded updated and installed TI software.

    When I open vst or au in Ableton. I have the same message/problem... The TI is connected to one usb port (only device).
    Definitely worth a look by the guys at access. I am pretty handy with computers but I have no idea how to fix this...
    My TI worked for years on my old Q6600 Windows...

    Is there already a (simple) solution???

  • Which version of the Ti software are you running?