TI2 desktop started acting buggy

  • My desktop has all of a sudden started to act a bit buggy, the 2 problems I've noticed so far are:

    1. The knob behaviour "Snap" doesn't act the way it used to, it just jumps to the position if the knob is moved instead of waiting for the knob to pass through.

    2. If I drag a patch from the part list on the left to the lower browser window, the upper window jumps to a different menu.

    I've already tried a factory reset and the bugs persist, I've made a short video of the browser window here

    I'm running OSX 10.9.4
    Logic X.1.0
    Virus OS

  • 1. I THINK, there is setting in virus menu how knobs act. If they snap or value scale. Somebody else can correct me if I'm wrong.

    2. Tested this myself and I think its "normal" behavior when you have selected some category.
    Set category to All and it shouldn't jump like that.

  • Hi supa,

    Thanks for checking. There is a menu to change the knob behaviour I normally have it set to snap, this should mean that the parameter doesn't change until the knob has reached that value. This was how it behaved until recently, now it instantly jumps to the position as soon as the knob moves. This causes me to make a mess of patches very quickly which is not what I want to be doing.

    I don't think it should be considered normal that a browser window changes itself like that without any interaction, especially as the page x of x display at the top of the window does not change even though the contents of the window does. I'm glad to hear it's not just my machine doing this.

  • I wouldn't go so far as to call my Virus a piece of crap, I love it and think it sounds amazing!! I use it all the time.

    I could live with the browser window oddness but the knob behaviour thing is frustrating, once I noticed it and have been unable to fix it with the usual methods I've started to wonder if there was something wrong with my Virus. It would be nice to hear from Marc or Jörg about this.

    So far I've tried a factory reset and re-installing the OS, the knob "Snap" mode still won't work like it should. Sometimes I will just nudge a knob to see what it is set to, if I do that now - instant change to the sound :(