Virus B button corruption

  • Hi there,

    My Virus B is behaving quite oddly - most of its buttons are working fine, but the Value, Parameter and Part buttons act unpredictably.

    When in Single mode, I press 'Value +' and once out of ten clicks, it increases the program. Nine times out of ten, though, it switches to LFO 2 Edit mode (as if I'd pressed LFO 2's Edit button). Further presses either cycle through the LFO2 shapes or occasionally increase the program number. Pressing 'Value -' goes either to LFO1 or Oscillator 1 but never decreases the current program.

    Parameter, in Single mode, does similar stuff - '< Parameter' switches to Multi mode, while 'Parameter >' generally cycles through LFO2 destinations.

    Most frustratingly, in CTRL mode, 'Part +' successfully cycles forwards through CTRL options, but 'Part -' doesn't cycle back; instead, it jumps to the EFFECTS menu!

    I sprayed contact cleaner on the PCB around where the buttons' microswitches are soldered, around the button housings themselves, and I also generally cleaned up the PCB with contact cleaner spray and a lint-free cloth. It seems like there's some crosstalk going on - like the buttons' signals are working but other circuits are picking up interference from them - but I guess it could be occurring anywhere between where the buttons are soldered and where the ribbon cable joins the mainboard...

    So I'm hoping someone can tell me whether they've heard of this issue before, and if there's any repair solution short of buying a new Virus B (which I really can't afford to do!). I have moderate skill in electronics and work in a research lab alongside helpful people with tonnes of skill, so feel free to suggest audacious challenges if you think they'll work ;)

    By the way, I put OS 4.9 and all the patches on fresh last night, to be certain it wasn't OS corruption of some kind. That went fine, and I can control all parameters with VQ from the computer. All the other knobs and buttons seem to be absolutely fine, audio output is fine, and I have to assume that all MIDI/SYSEX transfer is working fine too.

    Thanks in advance!

  • Since this is an issue with the internal multiplexing of the switches, I'd say that a part of the multiplexing circuit isn't working properly anymore. Could be one of the ICs used on the user interface PCB.

    It could also be a simple contact problem with the connectors, so re-seating the flat ribbon connectors is a worthwhile thing to try.

  • Hi abraxa, thanks for the reply and your theory on what happening.

    I re-seated the ribbon connectors when I cleaned the boards and still the same.

    One thing I noticed is that when I change preset/program on the unit, it mostly shows the LFO 2 page on the screen instead of the next preset,

    but if i change preset/program with cc from my Digitone it changes perfectly and always shows the presets (never going to LFO 2).

    Not sure what that means?

  • > Not sure what that means?

    It means the programs running on the Virus DSP and support MCU are working just fine - it's just the circuit for checking the button state that's broken - a hardware fault, likely on the user interface PCB, not the main PCB. Do you have a place that can check it out for you?

  • That makes sense and was what I was thinking it could be… thanks for that.

    No I don’t have anyone to check it. I did message Access support, so maybe they will recommend someone or i’ll have to find someone myself.

    Can you recommend anyone? i’m in Ireland.

    Thanks so much for your help on this abraxa :)

  • Thanks, I really appreciate the offer to look at the Virus for me! 👍🏻

    I’m going to see how I get on with it, as it worked flawlessly all day, the issue didn’t happen once… until the evening when I went into ‘Multi’, it was playing up after that.

    Seems something weird going on there, all the Multi presets have strange names like ‘U*U**L*H*’… maybe corrupt or the result of a part braking down?

    More trouble shooting tomorrow!

  • > Seems something weird going on there

    Indeed. I'd expect a hardware fault to either be always present or temperature-related, not appear in different modes of the device.

    > all the Multi presets have strange names like ‘U*U**L*H*’

    Maybe the battery that was placed in the Virus isn't fully fresh and has aged in the packaging? I'd try a new one cause that's SRAM corruption for sure.

  • Yes, that’s what i was thinking, very strange to be working 100% for a full day, I kept it working to fully test it.

    The battery suggestion is great! thanks! the battery i put in is from a new pack, but has been in a draw for a good while.

    Going to buy a fresh one and test it later.

    Thanks for that abraxa 😁👍🏻