Virus Ti2 and Midi Keyboard doesn't communicate

  • Hi,
    Im using:
    Mac pro 2014
    Logic X 10.1.1
    Virus Ti2 5.0.8.00
    Nativ Instruments Keyboard - Komplete Kontrol S61


    Ever since I updated my virus driver and my sound card driver i can't play the virus as a stand alone with my midi keyboard.
    I connected the midi cable from midi out of my keyboard to midi true/in of the virus.
    When i play the demo song in virus its ok and i get the sound out to my sound card .
    When I'm using the keyboard in logic its working just fine with the virus or any other plugin.
    I can't use the virus as a stand alone and play live because there is no midi communication between them .. as for my opinion.


    Anyone had/have this problem?
    Please Help!


    Niv.

    Virus TI2 Desktop. 5.1.6.05
    Mac Pro 6-Core Intel Xeon E5, 3.5 GHz, 32 GB Memory. macOS Sierra 10.12.2
    RME FireFace 400.
    Komplete Kontrol S61.

  • when you have the USB connected to the virus, the Virus becomes a 'midi hub' for the computer.
    essentially connecting a Virus to a computer 'says' let the computer do the routings explicitly, and disconnect 'internal' default routings from TI keyboard and midi ports to the synth engine.


    so if you want to connect your (NI) keyboard to the Virus sound engine, you need to make this 'connection' in your DAW.
    using Virus Midi (in) to Virus Synth(out), in a similar way to the way you connect Virus Synth(in) to Virus Synth(out) to connect your TI keyboard to the synth engine (and you can connect Virus Synth (in) to Virus Midi (out), to connect the TI keyboard to an external synth)


    it may seem like a 'faff', but actually I find it quite useful now...
    e.g. I leave my Virus connected to my Spectralis via midi cables
    when the Mac is off, is a direct midi connection, but when I turn it on, and start Live (with my template) , Live is 'magically' in the loop for recording midi and looping etc.

  • Hello "thetechnobear", i know its been a wile but i still want to figure out that point.


    If i don't want to use a DAW and i want to connect it directly so my set up will be ---> Komplete Kontrol Keyboard ---> Virus TI2 desktop ----> RME fireface 400 ---> Speakers.


    As for now i connect the keyboard MIDI out to Virus MIDI in... From virus main audio output to RME input... RME output to speakers.


    I don't have any sound coming out when i'm pressing a key (in keyboard) but i have sound coming out when in virus i press "audition" (Shift+ Search).


    What im doing wrong?
    What i'm forgetting?


    Thanks a lot.

    Virus TI2 Desktop. 5.1.6.05
    Mac Pro 6-Core Intel Xeon E5, 3.5 GHz, 32 GB Memory. macOS Sierra 10.12.2
    RME FireFace 400.
    Komplete Kontrol S61.

  • Hi there,


    I have the same exact issue, I've been messing around with parameters for a while now and researched that a lot, but couldn't find a solution.


    Did you sort the issue out by any chance?


    Thanks