[BUG] TI OS 5.1.3.0 - Freeze while auditioning patch

  • I can get my Ti 2 Desktop to freeze pretty easily if I do the following:


    - go to preset/patch (e.g. ROM-A 22 DampPtchBC, a Mono Bass, but "works" with any patch)
    - press SHIFT-AUDITION for several seconds to hold the note
    - shift the octave
    - change to a different patch (the note of the first patch is still ringing)
    - audition the patch
    - change back to the first patch
    - press SHIFT-AUDITION --> the note will not stop anymore
    - press SHIFT-AUDTION for several seconds --> a second note is hanging
    - press SHIFT-AUDTION a couple of times, throw in a couple of octave shifts for good measure


    ---> Virus will suddenly stop all other sounds and put out at full volume what sound like a narrow pulse wave at the pitch of E3, no controls work anymore, device must be shut down.


    I wasn't able to force that condition on TI OS 5.0.8.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete Ultimate 13 | RME Fireface UFX+

  • Spoke too soon. Can freeze it as well on TI OS 5.0.8.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete Ultimate 13 | RME Fireface UFX+

  • The same behavior can be acheived on a TI2 Polar/Darkstar.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete Ultimate 13 | RME Fireface UFX+


  • you can do this on every Virus. the question is why you need to do that ... ?


    I ran into it while I was auditioning sounds on the Desktop without a keyboard attached... happens pretty easily that way when flicking through sounds and trying out how they sound in different octaves.


    If that's not the intended use of the Audition function, then the question goes back: What's the intended use of that feature and why does it break the synth that easily?

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete Ultimate 13 | RME Fireface UFX+

  • Did you try it? It reads more complicated than it really is. And as already said, it happened while I was checking out sounds when I didn't have a keyboard available. Otherwise I'd never run into that.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete Ultimate 13 | RME Fireface UFX+

  • That user is me. And yes, as I explained there, it is a very simple way to get the TI2 crashed.


    I'm still a newbe to the TI2, just scratching on the surface of the TI2's capabilities.


    It makes me really wonder, why such a heavy bug still can be present in the firmware ... for more than 10 years of production.


    Just let me say, that this very loud buzzing sound is dangerous!

    If you're wearing headphones, your ears can get hurt!

    At least you get scared when that sound comes out of your speakers ...


    Unfortunately that is not the only bug, a newbe can run into when exploring the TI2.


    The simpliest way is to check out the demo song. Here the TI2 will randomly crash also, or voices get missing while the demo plays in a loop.


    AM support knows that; they say, that the demo song wasn't adapted to newer TIOSes ... and you shouldn't use it anymore for testing the unit.


    Sorry, but I have to say that is really sad for such a pricy device.


    I hope that we still get a bugfix for that kind of dangerous crashes!