Virus TI crashes on boot - suggestions please.

  • I recently purchased a second-hand Virus Ti Keyboard and was quite upset to discover that it freezes during the boot-up sequence. I tried holding down the EXIT key and switching it on and it successfully enters USB update mode (v1.03). I have tried to update it on three different laptops (WinXP, Windows 10 and Mac) but it always fails to find the virus. Examining the USB information on a Mac seems to show that it is just showing the basic Texas Instruments chip information. I tried running all the diagnostic tests accessed from EXIT + TAP on boot up, and they all complete successfully. I also tried reseting the system using Arp EDIT on powerup, which executes successfully, but does not solve the problem. The currently installed OS is

    I tried contacting Access Support who quickly replied asking for my serial number and num1 and num2 from the TAP+CONFIG boot sequence. After supplying this information, Access Support never replied to my e-mails despite repeated attempts to contact them. It seem that they were only interested when they thought my Virus might be a new one.

    If anyone can offer any advice on what to do, please help me. I have had a dead Virus sitting on my desk for over a month now and I am desperate to use it. I wondered if there is any way to reinstall the OS over midi using SYSEX if the USB firmware is corrupted. All suggestions most welcome.

    Thanks in advance for any advice,



  • I've had the same dealings with support recently, I got a response after putting it up on here, Marc mentioned they are having problems with response notifications ATM. try and submit a new support ticket including the previous correspondence with them. I got nothing again after my reply. I hope u get it sorted I'm sure you will get a response now it's up on the board. I gave up. Good luck hope you get it working.

  • Have you tried to update os through virus control center.
    Try to install the new os with installer, then open control center. see if it recognizes your Virus.. then try update os with it.
    maybe first time it could be better to try upgrade with some older versions of os and next put the last firmware.

    Sorry for my very bad english . I hope you have understood the concept :)

  • Thank you for the responses trancewave and Mark.

    The virus is not recognised at all by virus control centre whether it is in regular mode (i.e. crashed) or update mode. I have tried various different versions of the installer on different operating systems but it is never recognised.

    I got a response from support, but they couldn't offer any useful advice except to contact the Japanese distributor to buy spare parts. What I am trying to work out is whether the main board needs replacing, or if this could be a problem with the usb circuit on the ports board. Does anybody know if usb device chips are programmed with specific firmware for a device, or if they are just generic and essentially pass communication with the computer to the local processor? If I am going to pay for a replacement board, I want to replace the correct one!

  • I tried again this evening. I opened up the virus and made sure all the cables and connectors were securely attached. Neither the installer or Virus Control Centre will see the Virus.

    My USB update mode reads firmware v1.03

    If I use system information on the Mac, when attached, the Virus is reported as follows:

    Vendor-Specific Device:

    Product ID: 0x3200

    Vendor ID: 0x0451 (Texas Instruments)

    Version: 0.00

    Speed: Up to 12 Mb/sec

    Manufacturer: USB Device - By Haim Eliyahu

    Location ID: 0x14100000 / 10

    Current Available (mA): 500

    Current Required (mA): Unknown (Device has not been configured)

    There doesn't really seem to be any special circuitry for the USB port on the port board, so I guess the problem is with the mainboard.

    When the system is switched on normal, it starts to boot and get to "Please wait" and then does nothing else.

    It is reporting its own serial number correctly and all the diagnostic tests work.

    It looks like I will need to buy a new mainboard unless anyone has any bright ideas.