TI2 USB MAGIC ( unknown device)

  • Hello everyone,

    I tried almost everything and magic is still happening.

    I had a notebook (ux42vs) with virus ti connected thru usb cable, and everything worked perfectly

    Now i have bought n550jk. It has 2 usb ports on left side and one on right. And this is what i observed:

    Usb cable n.1. It didnt work in all the usb ports. Connectng virus through it, gives me "unknown device" message. On old notebook- no problems, everything works fine

    Usb cable n.2. Didn,t work in left side usb's, works in right side usb. Connected through usb hub ( virus->cable n.2-> hub->pc) works with one of two ports on left side, and in this one on the right. On old notebook- no problems at all

    Usb cable n.3. Work in all usb ports, on both notebooks.

    So, only one word is in my head. What the f**k is going on. Could someone help?

  • Well USB is a tricky thing. I would say the most likely suspect is the USB cable, make sure you are using the one that came with the Virus, a clear visibly braided cable. The reason could also be that you have different types of USB ports and the virus can only sync relyably over lower speed usb ports. Perhaps if you got an MTT Usb Hub that could deal with higher speeds then everything would work correctly? MTT hubs set the speed per connection rather than assuming everything is USB 2. Of course that won't work either if you don't have a beefy well insulated cable.