Virus TI / Mac OS Sierra 10.12 compatibility

  • My apologies if this has been covered in the forum recently (I didn't notice anything just now), but I've just had Mac OS Sierra 10.12.5 installed, intending to use it with Logic X (which I intend to buy shortly), but I forgot to check if the Virus TI's latest software is compatible with Sierra 10.12.5. Is anybody using this combination successfully? Thanks for any information!

  • ...including 10.12.5 ? I'm just concerned I might have to get an earlier version of Sierra installed.


    I think there are a couple of useres here who are working on with the latest macOS update without problems, me included..

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 10.5 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete 12 | RME Fireface UFX+

  • Just a short comment for your education coming from someone in software development: most software these days uses a concept called semantic versioning. There are three parts to a version number, major.minor.patch. The general interpretation is that patch version gets incremented for updates that just include bug fixes, minor version gets incremented for new features that don't break anything and major version for breaking API changes. So it is 'quite safe' to assume things will work consistently across one major version. :)

  • Generally agreed, but the question is how Apple handles those version numbers... macOS 10.12.5 is actually MacOS X version 12.5.


    Also, most software today uses build numbers which can be different for the same version.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 10.5 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete 12 | RME Fireface UFX+

  • Yes, I'll also concur, something around 10.12.5 has changed...


    I've another USB device (ML Soundplane) that now has issues running alongside the Virus TI.
    basically, the Virus USB mode no longer seems to initialise correctly if it is turned on AFTER the other device, and if it is turned on BEFORE the other device, then the other device does not initialise correctly. I cannot see anything wrong in the console etc.


    Interestingly, I've noticed that if I plug the Virus directly into the mac (rather than the MTT hub), it seems to work ok.
    (which is why I've not raised it as a bug report, as Access will just tell me its the hub, despite the hub working perfectly ok before ;))


    so yeah, Apple has definitely changed something... that's causing a hiccup, as was all fine in previous versions of 10.12 (and prior)



    side note: I suspect the issues involve the use of asynchronous usb io which is used by usb audio cards, my soundplane and alike - since other 'simpler' devices don't seem to be affect, and async usb has had various bugs associated with it, ever since Apple made major changes in El Capitan.
    I'm hoping eventually Apple will sort these issues out, but not holding my breath , till then I just try to workaround the issues the best I can.

  • Update - I now have the Virus connected via a Sonnet Thunderbolt USB3 convertor and the Elektron units on Overhub.


    It's all working!


    Not so long ago, Virus wasn't working on the Sonnet convertor, but now it is!


    :D


    Update 2: I am now getting random pitching glitches on the Virus. Delays randomly speeding up or slowing down.