Problem with Polar TI on new iMac

  • The following setup has proven impossible for me to get to function properly: iMac 2019, 5K 27", 3.6GHz i9, 64GB, Pro Vega 48 and Logic Pro X (10.3.2 (&10.2.0)).

    I've tried two different versions of Logic Pro X that worked without an issue on my old 2011 27" iMac with my Polar TI. Logic loads songs made on the previous system, but then says it can not find the TI. I've tried uninstalling and reinstalling the TI software to no avail. I've tried the plugging and unplugging as described in the TI software - also without success.

    I've also tried plugging the TI's USB into the ordinary USB 3.1 inputs on the iMac, as well as via the USB-C inputs (using Apple's USB-C to USB-A dongle). Nothing seems to help

    Strangely enough, the Virus TI is possible to select in Logic Pro X as an audio input and output, and I can clearly see that the MIDI is input when tapping the TI keyboard but the TI software still says the synth can not be found... Anyone able to help me with this issue?