Mystery Island V2 for Catalina Beta is out....

  • ok i have Virus HC working, i can see the imported patches from the virus now. But when i select one in the Virus HC the patch sound doesnt change. Must be some thing simple im missing? Midi is triggered correctly from Logic.

  • Ok i sent MI a video of this over a week ago, still no reply. Filter tweaks work to and from the app so midi is working.


    Virus HC asks for multimode, but then there is no sound from virus in multimode, it appears to work best in single mode.


    Any users here using Logic who can help?


    Why does the libriary patch change in Virus HC not change the patch in the virus?


    So frustrating.

  • Got it! Seems to be working OK.

    Top left says that the license needs reloading though. Any idea what to do about that?

    To load the licence, you have to go to the patch librarian section, click 'Bank Edit' button, then choose 'Register licence' from the drop-down menu.


    Bizarre location, which i only discovered when the plugin prompted me to register after about 30 minutes use

  • Using here the beta version (though I paid), you have to follow every step indicated on their homepage !

    and overall clear the virtual cable port out of the physical output in the environment, if not it permanently crashes logic on Catalina cause of midi loops

    Virus TI2, Prologue 16, Summit, Triton, Komplete Kontrol 49, UAD Apollo x6 and TwinX, Yanaha HS7 and HS8S, AKG C3000, MacMini 2018 i7 1GB/64Ram, MacBookAir 2017, iPad Pro 2017, Nektar Impact 25, LogicPro, a lot of plugins…

    Edited once, last by SeleN ().

  • I've started using this and after a bit of a rocky start, I'm finding it very stable, and a great replacement for Virus Control. Working out how to save patches took me quite a while, and it stills seems a bit flaky, sometimes not working at all (for anyone else getting stuck, you hit the red save button, then go to edit bank, and save from there). Would love it if that was a bit simpler.


    One big problem in Ableton (and I don't think this is Mystery Islands fault) is you can't really record automation per track, as everything gets saved to the track with the VST on it, which renders it pretty useless. There's a workaround of sorts here: https://www.elektronauts.com/t…ton-live-setup-tip/131343 but it requires Max for Live, and an instance of the plugin on every MIDI track. Has anyone found a better way of dealing with it?