Ti Plug doesn't recognize Desktop Virus ••••SOLVED••••

  • Mac High Sierra. USB connection. Virus OS 5.1.7


    Synth is recognized by DAW and is playable. Open plug in to change preferences and get the "there's no Virus here" screen.


    When I try to play the demo, the only thing I hear is a synthetic Kick drum coming through output 1-2, which are the only outputs I have connected. I'm assuming that this is because the previous owner had it setup differently internally, and it's my understanding that I need the plugin to change this setup.


    Am I off? Any assistance would be greatly appreciated.

  • I‘d first do a full backup using Virus Control Center (just in case...) and then try to reset the unit to factory settings.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete 12 | RME Fireface UFX+

  • Okay, before I do that, I made SOME progress. I had installed the latest software when I first got it, and went through the process with no problem, but I was connected via a hub, so just on a hunch, now that I'm connected directly, I reinstalled that software. It didn't connect at first, but after two tries of "hold the exit button, reboot, and try again", it displayed "USB connection established." So.....you would think problem solved.


    But no.


    The plug in still won't recognize anything in either Logic or Ableton. This is getting frustrating. I've never had this many problems getting a synth to just FUNCTION and I've been at this for a while.

  • UPDATE:


    If I use an external instrument plugin (Ableton 10) the Virus functions like my other external synths. I can play it via my controller and I get audio output from the analog connection. Since no MIDI cables are involved, I KNOW the USB connection is good. And this was reinforced when I re-updated the firmware. It even said "USB Connection Established".


    I'm disappointed in the execution of the Total Integration, which, at this point, is anything BUT total. It's not even partial! I LOVE how the unit sounds, but it's archaic that I have to manually step through the patches one...at...a...time. I have third party editors for my other synths, but the whole Ti thing was supposed to do that and I IIRC, there are no other solutions for integrating the synth into a DAW. I have done everything suggested by all comers on three different forums, and nothing works. I have read and re-read the manual and I'm doing everything I'm supposed to. I have done a factory reset and restarted the computer no fewer than a dozen times.


    Really frustrating.

  • captainarko

    Changed the title of the thread from “Ti Plug doesn't recognize Desktop Virus Ti” to “Ti Plug doesn't recognize Desktop Virus ••••SOLVED••••”.
  • To anyone who's been following along and might have the same problem, here is the fix.


    Evidently from Mac OS 10.12 Sierria and up, Privacy and Security settings prevent the TI drivers from operating. You need to restart and immediately to to

    System Preferences/Security and Privacy. You will see that it has blocked "Ploytec GmbH" from loading. Allow it to load and restart. The TI plug in will then operate as it should.