Posts by ChrisCabbage

    I'm not a coder myself but from what I've gathered is that because the Virus TI chips are very old, they only support low level ''machine'' code.

    Since most modern chipsets support higher level code languages like C++ It's probably very hard to find an old school programmers that can do low level coding, and if there are, they're probably quite expensive. So maybe Access isn't willing to spend as much, but publicly they don't want to burn the bridge just yet since that will hurt the sales.

    The driver is for the Mac side, not the TI side.

    I've had to take a different tack for now. For legacy projects and transferring patches), I've installed Mojave dual-booting. Then, I just have a cut-down set of plug-ins for those projects. No need to install Cubase on the Mojave volume, since it can be called from the main Catalina volume with an alias.

    Then I'm using the Mystery Islands plug-in for new projects. It's not 100% stable though. It's caused a few crashes.

    Since I can't easily get multiple Virus outputs working, I'm limiting Virus to mid and high frequency patches on a single pair of outputs. For bass, I'm using other synths.

    ...but obvs., I'd really like the Virus plug-in working on Catalina - as soon as we can have it! :)

    Contacted Access about the timing issue. here's what they had to say:


    ''When using the Virus TI plugin and using the analog outs, this cannot be delay compensated by DAWs due to technical restrictions in general. There is also no setting that would influence this at all. You can try to see if using different buffer sizes might help, but again the signal from the analog outs cannot be delay compensated in general with the plugin being in use (and this never was the case.''


    So basically there's nothing we can do to fix the timing when using the analog outs.

    Yep. Pretty-much what I thought, despite being told otherwise by various people.

    This is inaccurate. You have to enable midi in the plugin if it is running, and then it will work. Its on the tab on the right. You will know you are looking at the right page when you see a picture of the Virus panel. "Enable Midi" is in the dropdown. Otherwise just enable midi via the keyboard itself if you want to forgo the plugin altogether.

    The "Enable Midi" you're referring to I think, is the "Enable Midi Channel" item under "MIDI Channel Behaviour" on the "remote" setup page...?

    I don't think that it has anything to do with reception of MIDI note data. Enabling it, doesn't enable reception of MIDI note data.

    I *think* my original statement is not inaccurate. I'd be very happy to be proved incorrect though!

    Edit: from the manual, what that setting does is:


    "MIDI Channel Behaviour

    Select whether or not the controller messages are sent to the

    specific channel as determined by the MIDI string, or whether

    this part of the string is ignored, and the messages are sent to

    the currently selected channel."

    This is inaccurate. You have to enable midi in the plugin if it is running, and then it will work. Its on the tab on the right. You will know you are looking at the right page when you see a picture of the Virus panel. "Enable Midi" is in the dropdown. Otherwise just enable midi via the keyboard itself if you want to forgo the plugin altogether.

    I honestly hope I’m wrong. I’ve asked many times, on multiple forums (including this one) if there’s a way to do this and I’ve never had a useful response. I’ve seen many others ask the same question and it’s never been answered.


    I’ve also just looked at the manual again and I can’t see a mention of this.


    could you be specific about which “panel” enable midi is on? Which drop-down?

    Thank you for the quick answer.


    So, I understood, that the original Virus-Plug-in only allows for MIDI via USB. To send MIDI through a MIDI interface, a third-party-plugin needs to be used (like from mystery islands or MidiQuest).


    Question: Does the timing issue become better, if both Midi and Audio are sent through dedicated interfaces ?

    My understanding, is that the plug-in only works with its own USB connection. When the plug-in is running, you can't separately send MIDI to the Virus over USB (or DiNs), without going through the plug-in.

    Mystery Islands is one way forward. I use that, but do prefer the Access plug-in.

    Again - I'd love to be shown a better way of doing this, but so far haven't found a way.

    Timing is better, if you treat the Virus as a standard external instrument. In my case, I'm setting up my DAWs to use Virus as an external instrument, with PDC applied. USB MIDI and DiN are pretty-much the same timing-wise, when working in that mode.

    Timing is also good for me, if I use the full Ti plug-in system, with USB audio. Obviously, we're waiting for a Catalina update for that.

    Of course, I would prefer the built-in Total-Integration-USB-solution, because it saves me 6 audio-ins on an interface. Nevertheless, I do not want to miss the Virus TI and I am prepared to invest in a dedicated audio/midi-interface for the Virus. If it works ....


    Thanks a lot !!


    Stefan

    Hi. It kind-of works, but I find that the timing becomes very unreliable and jittery.


    Also, Virus doesn’t receive MIDI via anything other than the plug-in, if the plug-in is running.


    I’d like to be proved wrong on all that though.

    Ploytec still haven't released their Catalina UAB Audio driver yet... I'm assuming that's also what Access are waiting on as well. - https://www.usb-audio.com/support/

    If Elektron are using it for Overbridge (which is what we’ve been told), then they might have a version they’re releasing to partners, but not one they’re yet happy to publicise. Conjecture of course.


    ...or they might just be terrible at keeping their web-site up-to-date. 🙂

    well you need to learn to explain your problem more clear in the future.

    What are you saying, that the plugin sending midi to the virus and then the audio coming out of the D/A instead of USB, is not compensated correctly? Do you realise how microscopic that latency is? You are being ridiculous. EVERY hardware synth has output latency,

    You appear to be trolling now. I’ve been working with synths and recording kit for more than 30 years now. I’m also a software engineer, working in embedded multimedia systems. I know a fair bit on what I’m talking about.


    I’m not obliged to help people like yourself mate. Good luck with finding solutions to your problems. I’m no longer responding to your posts.

    In case it helps (just noticed the latest posts on here), this is where I got to when using the analogue outputs.

    I've actually got reasonable-ish results in Cubase 10.5.11, using the external outputs, but timing isn't completely consistent and there's a fair bit of timing jitter.

    Here's what I'm having to do:

    Plug-in set up with analogue outputs, into one of my RME Mulitfaces.

    Live mode on the plug-in checked. This is the crucial bit! ...and you'll need to check it every session, since it doesn't get remembered.

    Virus set up as an External Instrument in Cubase (you'll have to check the guides on how to do that).

    MIDI channel sending to plug-in (e.g. 01. Virus TI - Midi In).

    To test, I have a group channel, with the External Instrument instance routed into it. Then an audio channel, with input as the group channel. I then record the audio on that channel and check the start timing. I'm using an Init patch, with Osc Phase Init set to 1.

    It's not straight-forward, but it's kind-of useable. Hope that helps!

    If anyone has a better solution, please do respond.