Posts by captainarko

    I've spent the last couple days wrestling with my new-to-me Virus Desktop, as well as a Prophet Rev 2, and a Novation Peak which are not so new. I use them all as standalone instruments, and track with them old school. Not using any TI. So I've been trying to find a way to scroll through the patches quickly while auditioning sounds and I felt like I should be able to do it from one place, i.e. my S88 controller. All that turning around, or leaning forward while keeping one hand on the keyboard. I wanted to do it like I've always done on my keyboards. Sit with one hand on the keys and the other just to the left of it on whatever knob changed patches. Not stretched like I was playing Twister.:cursing: Well, patch changes were no problem, but bank select on ANY of them turned into a giant PITA.


    Long story short, I found a lovely little Max for LIve device that does just that. Sends Program Change and Bank Select messages. Installed that before the external instrument plugin for each synth, opened Komplete Kontrol and assigned the six knobs free CC #'s, tailored each knob range to match the bank range of its synth, and VOILA!!!!!


    IT LIVES!!! 8o8o8o


    Works like a charm. Two days of scouring the internet for answers and all I had to do was remember, "Oh yeah, Max. I bet somebody made something for that." And if not, well...you can make it yourself.


    Maybe it' time for a walk outside. I hear that's supposed to be good for you.

    To anyone who's been following along and might have the same problem, here is the fix.


    Evidently from Mac OS 10.12 Sierria and up, Privacy and Security settings prevent the TI drivers from operating. You need to restart and immediately to to

    System Preferences/Security and Privacy. You will see that it has blocked "Ploytec GmbH" from loading. Allow it to load and restart. The TI plug in will then operate as it should.

    UPDATE:


    If I use an external instrument plugin (Ableton 10) the Virus functions like my other external synths. I can play it via my controller and I get audio output from the analog connection. Since no MIDI cables are involved, I KNOW the USB connection is good. And this was reinforced when I re-updated the firmware. It even said "USB Connection Established".


    I'm disappointed in the execution of the Total Integration, which, at this point, is anything BUT total. It's not even partial! I LOVE how the unit sounds, but it's archaic that I have to manually step through the patches one...at...a...time. I have third party editors for my other synths, but the whole Ti thing was supposed to do that and I IIRC, there are no other solutions for integrating the synth into a DAW. I have done everything suggested by all comers on three different forums, and nothing works. I have read and re-read the manual and I'm doing everything I'm supposed to. I have done a factory reset and restarted the computer no fewer than a dozen times.


    Really frustrating.

    Okay, before I do that, I made SOME progress. I had installed the latest software when I first got it, and went through the process with no problem, but I was connected via a hub, so just on a hunch, now that I'm connected directly, I reinstalled that software. It didn't connect at first, but after two tries of "hold the exit button, reboot, and try again", it displayed "USB connection established." So.....you would think problem solved.


    But no.


    The plug in still won't recognize anything in either Logic or Ableton. This is getting frustrating. I've never had this many problems getting a synth to just FUNCTION and I've been at this for a while.

    Mac High Sierra. USB connection. Virus OS 5.1.7


    Synth is recognized by DAW and is playable. Open plug in to change preferences and get the "there's no Virus here" screen.


    When I try to play the demo, the only thing I hear is a synthetic Kick drum coming through output 1-2, which are the only outputs I have connected. I'm assuming that this is because the previous owner had it setup differently internally, and it's my understanding that I need the plugin to change this setup.


    Am I off? Any assistance would be greatly appreciated.

    Mac, High Sierra 10.13, Ableton (to start with...PT and Logic to follow), USB for now. Considering breaking out the old MTP AV and going MIDI because of wonky synth behavior.


    I have no desire to delve deeply into the whole total integration thing. I simply want to use it as an external synth and have the editing/automation capabilities of the plug in. Can I still do that if it's only connected via MIDI?