Elicenser / iLok Fails When Virus TI Is Plugged In

  • Hi Folks,

    Weird one here.

    I've just got a new Mac Pro and have been configuring it. I've got the 6-Core base model which has 4 USB 3 Ports. Annoyingly, everything seems to lump on to the same bus so there doesn't appear to be a way to get rid of the message when loading the virus plugin in Cubase (sharing resources with..). I've tried every port with the TI on its own.

    I have two Belkin F5U237 7 port USB 2 powered hubs (new one arrived today) that show up as USB 2 MTT hubs in system report so I thought I'd try the TI on these as they had been recommend in the past and to be fair they have been excellent. Whenever the TI is plugged in to either of these hubs though or any of the two remaining ports on the front of the Mac Pro, the license centres can't find the keys and throw up error messages. Obviously I can't run Cubase or my plugins without them!

    After a lot of investigation I put it down to the fact the power supply had gone on the original hub with the license keys in as I read some reports that the elicenser required a lot of current and presumed it wasn't getting enough and therefore not working with other peripherals plugged into that hub that also required current. That's why I ordered a new identical hub because the power supply was actually more expensive! Anyway, having tested the supply it appeared to be working fine and plugging the keys in without the connection to the computer did indeed confirm the power supply was working so that turned out to be a wild goose chase. Also, what baffled me further on this is that the TI does not require any power from the hub!

    Has anybody got the slightest idea why the TI would knock out my license keys when plugging it in pretty much anywhere? The Reason dongle which uses code meter and basically shows up as a hard drive is not affected at all so perhaps that could be a clue? Not a great start to my Mac Pro experience!


  • i have a belkin 7 port hub for all the keys and one in between the TI and my mac. unless you put nothing else into the hub serving the TI, this should work good. make sure you use a power supply on the hub with the licensers.
    best, marc

    Hi Marc,


    It would seem I have a unique problem here unless I'm missing something obvious!

    Are you familiar with the new mac pro usb ports? All I know is there are four of them and they are usb 3 and appear to share resources, hence the message from the TI when loading up the plugin.

    Since this is only a problem with the Elicenser and Ilok, I put them on their own exclusive ports straight into the mac pro, each port should supply enough current for them you'd think?

    I put the TI into its very own Belkin 7 port hub, psu and all, and then it's very own port on the mac pro(as you suggested). Thats like a pent house suite if you ask me :) But still the licensers are disabled until I unplug the TI and they fire up immediately.

    I'm rather baffled by this to be honest. I've never had this before, ever.

    My concerns are either the hubs are faulty, the OSX drivers are buggy, the TI drivers are buggy, or worse than that the mac pro usb configuration is bad and thats all you'll get :(

    Just to confirm, the TI 'WILL NOT' let my licensers work, even when I dedicate a whole belkin hub and a dedicated mac pro port for it. The only way I can get them to work together is by plugging the TI into the lower left mac pro usb port, tried and tested.

    It seems like a power issue to me but the belkins psu are supposedly giving out 3.5amps per hub plus built in should be dishing out enough current to feed a couple of keys. Why would plugging in the TI, that requires no resources into any hub / port bar one knock out my protection devices?!


  • AJ - the Virus works with both eLicensers and iLoks. in my personal opinion, eLicenser keys sometimes have issues with insufficient power over USB and it appears that you need to take them off the bus to reset them once the OS cannot find the keys anymore. this has nothing to do with the virus ti. i have 2 eLicensers and 2 iLoks on a belkin 7 port hub and the virus on another port. it works as expected.

  • i have 2 eLicensers and 2 iLoks on a belkin 7 port hub and the virus on another port. it works as expected.

    What version ilok and elicenser are you referring to and what computer do you use Marc? I have an iLok 2 and the current elicenser (I presume!) that actually has elicenser printed on the key. I have a couple of pervious steinberg ones I could try.


  • What version ilok and elicenser are you referring to and what computer do you use Marc? I have an iLok 2 and the current elicenser (I presume!) that actually has elicenser printed on the key. I have a couple of pervious steinberg ones I could try.


    these days it is 2x iLok2 (but the old ones i had before in the same configuration work as well). the eLicensers are a Cubase key and another key which holds NFR licenses (i think it originates from VSL). those are a couple of years old. i usually working with a MacPro from late 2008 but a MBP from 2011 for instance works as well.
    best, marc

  • I'm having almost the same problem. This is interesting extra info - thanks!

    I also have Steinberg's eLicencer and iLok2, plus Virus. Ultimately, I'm going to want to add a whole load of USB audio-related devices, e.g. Korg Kronos. Roland TD30, Line 6 HD500X etc., so I'm going to have to work out how to get Virus to play nicely with all this other kit.

  • Hello,

    I have the same problem with MacPro late 2013. I have a Crossion 7-port usb 3.0 HUB for connecting my iLok, eLicenser and other MIDIMATE cables etc…I have a Manhattan USB2.0 MTT Hub for VirusTI Only. When I try to run all devices at the same time, the Steinberg eLicenser doesn't work. When I turn off the VirusTI, eLicenser works well.. I've tried to connect the eLicenser USB key directly to the MacPro and to the USB 2.0 HUB only connect the VirusTI but it doesn't help:((

    I have MacBook Pro, and this configuration works well with it...

    Any sugesstions ??

    best regards

  • Hi, Sorry for late reply I've been off line for a while.

    If memory serves, I do believe it was the bottom left port. I'm not set up at the moment or I would confirm this for you! What a bizarre problem though aye?

  • Hi Folks,

    Breaking news...!

    My Mac Pro had to go in for repairs recently so I hooked up my Macbook Pro whilst that was happening. What I had forgotten though was I had enrolled my Macbook into the El Capitan beta program. Upon hooking stuff up and updating software etc. (inc TI beta), to my surprise everything was working just fine.

    To cut a long story short, the late 2013 Mac Pro will allow the Virus TI (MKI in my case) to work on a Belkin hub without disabling E-Licenser or iLok with El Capitan installed.

    I wasted a day of my life trying to get the TI working with Yosemite and eventually buckled and installed the Apple El Capitan beta on my Mac Pro. Now works on all my hubs etc but of course I give my special machine it's own little place :)

    I have to say, for a beta this OS is far superior and so far is a joy to work with, plus I've got my TI back. Wether this was a joint fix between Apple and Access I'll never know but that's the fix guys. If you're not pushed I'd recommend giving it a whirl.

    Marc, my hard work deserves a T-Shirt, Mug (me), or DarkStar..........Thanks :)

  • Crumbs!

    You may be right. This looks like a big improvement.

    I've just managed to get the Ti plug-in running on my Mac Pro, with the system already running before I powered up my Virus.

    I've *never* been able to do that before on this system.

    Now, I'm sure Access aren't going to recommend running with this beta, but this is looking very promising.

  • Good to hear ChrisCabbage! Obviously betas aren't for everyone if you've got deadlines etc but I have to say I'm very impressed with this version of OSX.