TIOS has been released

  • I suspect everyone at Access is enjoying a christmas vacation, otherwise they'd have noticed that 3.3.4 doesn't work and taken it off the site.

    of course most of us try to try to take a break but from what i see from the download / support ticket ration, it doesn't seem that there are to many problems (or people just don't complain ...).

    happy xmas to everybody by the way!


  • I had no problems updating my Virus TI (1) Desktop to 3.3.4 under Windows 7 x64.

    I did however come across another strange interface bug (in addition to the known laggy interface).

    If I press the Enter key, VC crashes and then reloads itself. This happens with both Enter keys on the keyboard, and surprisingly it happens whether or not VC is the active window!

    System details:
    Windows 7 x64
    Ableton Live 8.0.4
    TI OS 3.3.4
    Dedicated Texas Instruments PCI express USB card

  • of course most of us try to try to take a break but from what i see from the download / support ticket ration, it doesn't seem that there are to many problems (or people just don't complain ...).

    :whistling: ... Some more afflictions:
    This thread has got a huge read-only popularity therefore I guess most users prefer to have christmas vacation. They hope those afflictions will sort out the problems for them without the need to write a single letter :rolleyes: .

    >>WINXP SP3 | C2D E8400 _ 4GB RAM _ 40GB SSD - System _ 1GB - Data | LIVE 8.2.2 Suite<<

    Edited 4 times, last by reflective ().

  • "Thanks for heads-up. I was sort of hoping for Win 7 GUI slowness to be fixed after all this time. :(

    Anyway tried to install over 3.3.0 results in "Virus TI Software Suite
    64 bit Setup ended prematurely" messege and cannot continue. Tried
    uninstalling 3.3.0 but that doesn't work either. So I am stuck here.
    What's up with these installation issues? :q

    Win7 64 here.

    EDIT: Reinstalled 3.3.0 beta successfully. Tried to fresh-install 3.3.4 release but same "prematurely ended" error. "

    Getting the same error. After trying to upgrade over deinstalled everything using uninstall, ran ccleaner to remove any reference and glarys utilities to clean up after reboot.

    Attempted install of 3.3.4 andsure enough auto roll back. Installed and all is fine, so no for the time being.

    Running W7 x64 Ultimate.

  • Reinstalled 3.3.0 beta from 3.3.4 not Help
    Firmware not roll to 3.3.4


    You have chosen an input/output configuration whitch allows for side chain inputs. This sequencer host software does not fully support audio inputs for software instruments

    Ti Desktop SL 61
    Win7x32 On Mother Gigabyte GA965 S-3
    RME FF400
    2XPowercorePCI MKII

  • Rollback failure here too. Had 3.3 beta installed, Win7 64.

    Command string is: msiexec /l* install.log /i "Virus TI Software Installer 64-bit.msi"

    Abbreviated log:

    and then a little further down, explaining the (botched) rollback:

    Looks like some of your custom action code is a little wonky :)

    If you want the full logfile contact me via the email address on my customer account. Thanks!

  • I thought as much!

    Last week I wrote tech support that something very basic is going wrong i.e. the installer stuck whilst trying to uninstall older drivers or rather install the new ones.

    Hope to see TIOS 3.3.5 very soon! :thumbup:

    >>WINXP SP3 | C2D E8400 _ 4GB RAM _ 40GB SSD - System _ 1GB - Data | LIVE 8.2.2 Suite<<

  • works fine on windows 7 32bit here. had no problem to install it.

    the GUI performance has improved as well. though it's not perfect yet. but much faster response now.

  • two setup needed for me
    w7 64 with cubase 5.1.1

    any automation possible :(

    a lttle bit rapier when changing menu in VC

  • In the interim would it be possible to get a copy of without the installer? i.e. one folder with the drivers, another with the VSTs, and such that the more computer-literate of us can install?

    I would have plucked this stuff directly from the MSI package but opening it up in WinRAR reveals an unexpected amount of gobbledygook that I have not seen in my own Windows Installer projects.

    Judging by the log files it looks like the only thing going wrong is the faulty CustomAction which installs the drivers, which can be done manually.

    Going to try cracking the file open with some other tools (http://blogs.pingpoet.com/over…ive/2005/11/16/14995.aspx)....

  • As I said previously, installs fine on Windows 7 x64, and works in both Cubase 5.1.1 and Ableton Live 8.

    Still got quite a sluggish interface, though this is not reported to be fixed yet.

    Seems to lose the USB connection though. By this I mean that unless the TI is turned on prior to bootup, the driver is not visible in Device Manager, and VC cannot establish connection in either host.
    Restarting the host and PC with the TI turned on sometimes fixes it.

  • Update on previous post:

    Cracked open the MSI with aforementioned tool

    Virus TI audio driver manually installs fine
    Virus TI midi driver manually installs fine
    Virus TI USB driver does not install. If you "have disk" the entry in Device Manager Windows says that it cannot verify that the driver works with the device.

    Firmware updater wont start, "payload missing" (even though I can see it right there)
    Couldn't find the regular Virus TI VST2 plugin, just Virus TI Snow VST2.
    Found VST3 package but unsure of where to put it (I know theres a folder for it just forget where)
    ASIO drivers not functioning (for rather obvious reasons :) ) though I can use ASIO4ALL to get audio output via USB.

    3.3 beta uninstalled (I think...) and there is no entry in my Control Panel > Programs list.

  • I believe the Virus TI Audio Driver 2.8.31 to be causing high DPC latency.
    If this is correct (other users should test and report) this is a serious issue that must be resolved before this OS can come out of beta, as high DPC latency results in pops and clicks in audio streams.

    With the TI Audio Driver disabled in Device Manager, I get latency around 20-50us, but with it enabled it jumps to over 100us with spikes of over 150us and occasional (every few mins) spikes of over 2000us.

    Enabled #1
    [Blocked Image: http://img163.imageshack.us/img163/1441/enabled.png]

    Enabled #2
    [Blocked Image: http://img192.imageshack.us/img192/4002/enabled2.png]

    [Blocked Image: http://img46.imageshack.us/img46/3250/disabled.png]

  • I contacted Access support and they recommended that I unplug every other USB device except for the TI, which I did. I then rebooted my system and Ti and ran the install. I still go the warning from the notification area of the Taskbar about a driver failing to install but the install continued successfully without rolling back.

    I'm now running 3.3.4 on Windows 7 x64

  • I did wanna install this, because I was afraid it would screw up my Virus, but since some people managed to install this, I thought Ill give a shot, installed it, and it gave me the prematurely ended error, and didnt install. I had to reinstall the old 3.3.00 driver to get it working.

    Its interesting how some people get it to work and some dont. Did the people who had before cant get it working, or the people who can get it working had other version like

    I have Win7 32bit, and I cant get it to install.