MacBook Pro High Sierra 10.13.6 comparability - does not recognise TI

  • Hi All

    I have just bought a newer MacBook Pro which has OSx High Sierra 10.13.6 and I cannot get the Mac to recognise my TI. I have followed the video explaining the new security features of High Sierra, and have clicked the allow button for access to this developer, but nothing happens when I do this and my TI is still not being recognised. I have also just submitted a support ticket and have had an automatic email response.

    Thought I'd also post here just in case anyone else has experienced this issue.

    The message below the video asks about third party mice/keyboard/trackpad - I have installed all official Apple products; the Apple Magic Mouse, Apple keyboard, and Apple Trackpad - and cannot get my TI to be recognised.

    While I await a response from Marc or another support expert, I thought I'd ask does anyone else here have any suggestions please?

    Many thanks.

  • please contact support by email. i'm using 10.13.6 myself and it works.

    Yep, thanks for the reply. I did so Marc. Not sure if it were you I liaised with, but the resolution was for met to do a clean install of High Sierra, after which it works perfectly. I purchased the laptop off my son (for a bargain!!!) who must have used a 3rd party mouse or keyboard during his time with the machine, and though it was a pretty new install of High Sierra he was using, the TI plugin wouldn't work at all and I could not authorise the software.

    So, I simply did a clean install, and voila!

    Must say though, despite the information provided not working, the speed of response and customer service I received - given I have a 10 yr old TI - was just superb. I will NEVER sell my TI. You may not produce synths anymore, but I adore my Virus.

    PS: new post in another thread that I could do with your advice on pls :) haha

  • Almost did a clean install of Mohave myself for the exact same issue when I accidentally fixed the problem by turning off "Secure boot security" by booting into the recovery partition of Mac OS 10.14

    Here is an article on how to get there, this fixed my problem where otherwise my machine was not able to see the Virus either in Virus control centre nor inside Logic Pro X. Hope this helps someone!

    Just change to "No security" for the Secure boot menu. I also changed External boot to "Allow booting from external media" also though I feel this may not be related.

    This could help avoid completely wiping your machine needlessly for the same result.