[BUG] Virus TI automation issue when using VST2 plugin VC on Mac OS

  • today i tested this issue on another macbook with mojave.


    i tested on two DAW's: Cubase Elements 10 and Reaper - results are about the same


    Cubase Results:

    VST 2 plugin (don't work correctly)

    VST 3 plugin -work FINE automation


    Reaper Results:

    AU plugin (don't work correctly)

    VST 2 plugin (don't work correctly)

    VST 3 plugin - work FINE automation

    conclusion: VST 3 plugin of virus control only works correctly

  • Cubase Results:

    VST 2 plugin (don't work correctly)

    VST 3 plugin -work FINE automation


    That made me curious and I tried it myself. Same result.


    VST2 overwrites Filter 1 Cutoff automation

    VST3 works as expected


    On Mac OS X Sierra 10.12.6


    So, this has nothing to do with Mac OS Mojave, and thus you ran into a probably pretty old bug. I'd recommend to use the VST3 version, which is generally better and more stable than the VST2 version.


    Please change the title of your thread to remove the reference to Mac OS Mojave.



    PS: Automation for the AU version works fine in Logic X 10.4.3

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Sub 37 | Voyager RME | Machinedrum | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS 13.5.1 (Ventura) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete Ultimate 13 | RME Fireface UFX+

    Edited 2 times, last by ozon: Added result of test with AU version. ().

  • i've never heart about this issue before. it surprises me a little because what you do is nothing really special. what I know through is that Virus Control doesn't really differentiate in between different types of controllers, in other words, something like this should happen to every parameter in the same fashion. it would be interesting to learn if what you've found also happens with earlier versions of cubase.


    in any case, i'd like to recommend to you to use VST3 instead.