Anyone tried Virus on MacOS Mojave yet?

  • However...... I did get a notice on the Mac today saying that the Virus Ti MIDI Driver is 32 bit and so it won't work after the next macOS update... this is worrying! So, what's the latest news about a full 64 bit macOS version of the Virus Ti2 software please? Thanks.


    EDIT: It appears that the /Library/Audio/Plug-Ins/HAL/de.access-music.virus_ti.plugin/Contents/MacOS/de.access-music.virus_ti - is 32 bit and also the /Library/Audio/MIDI Drivers/Virus TI MIDI Driver.plugin/Contents/MacOS/Virus TI MIDI Driver as part of the MIDIServer process is also 32 bit.


    Mark? Can you advise please Sir? Thanks man.

  • Can anyone comment on which DAW and setup they are using with success, please? I just ordered a new Mac Mini and keeping my fingers crossed that all TI functions operate well.


    I ran a test on an older MacBook Pro with Mojave and it wouldn’t even find my Virus. I typically run a PC for my audio work and this will be my first Mac in the studio. I’m a little nervous!


    EDIT: Got it working... the driver was being blocked and needed to be released in the security settings.

  • Hi all,


    I'm on Mac OS 10.10.5 and Logic 9.

    Appreciating now that perhaps its time i update to Logic X and of course latest version of Mac OS.


    I'm unable to update to the last known supported Mac OS of 10.13, so understandably I'm nervous about upgrading to 10.14(/Mojave).


    Marc/Anyone - when will we have a compatibility confirmation?

    ------------------------------------------------------------------------
    iMac 27", Late 2013 - Running OSX Yosemite 10.10.5
    3.4GHz Intel Core i5 CPU
    8GB 1600MHz DDR3 RAM
    1TB HDD
    NVIDIA GeForce GTX 775M 2048MB GPU
    -
    M-Audio FastTrack Pro - Running 1.9.5
    Access Virus TI2 Desktop - Running 5.1.7.0
    NI Maschine MK2 - Running 2.6.9
    AKAI MPK25
    -
    Logic Pro 9.1.8

  • Just updated macOS from 10.12.6 (Sierra) to 10.14.2 (Mojave) yesterday. Everything seems to be fine, actually working better and faster.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete 12 | RME Fireface UFX+

  • I'm struggling to get my TI to work on Logic Pro X on my brand new iMac (3.6GHz i9, 64GB, Radeon Pro Vega 48) with Mojave. I can see Logic reacting to the MIDI input, but no audio. I also keep getting the "No Virus TI can be found" error message in Virus Control. Have tried the suggested reset, checked different USB ports (incl. USB-C via an Apple USB-C to USB dongle). Anyone able to assist?

  • I'm struggling to get my TI to work on Logic Pro X on my brand new iMac (3.6GHz i9, 64GB, Radeon Pro Vega 48) with Mojave. I can see Logic reacting to the MIDI input, but no audio. I also keep getting the "No Virus TI can be found" error message in Virus Control. Have tried the suggested reset, checked different USB ports (incl. USB-C via an Apple USB-C to USB dongle). Anyone able to assist?

    Did you 'Approve' the security request when you loaded the software the first time? If not then reboot your Mac, when the desktop appears again, go straight into System Preferences, Security & Privacy, and click the approve button at the bottom. Hope that helps.

  • Same issue! :rolleyes:


    Currently trying to get my Virus TI 2 to work with my brand new macbook pro 2019 . Mojave 10.14.5 . 2.4 Ghz i9, 32 GB ram.


    Ive used my TI2 desktop for 10 years now. Best most versatile thing out there. Still. IMO. WHEN IT WORKS.

    I KNEW this wasn't going to be easy (never has been with the virus)


    I'm connected via laptops USB-C -> multi USB hub


    The macbook/logic recognises the audio device being connected, you can choose to use at as a sound card, however the Virus control software is not working.

    The famous/dreaded message 'No Virus can be found.' appears.

    I have followed the suggested steps but to no success.


    In the past I had a Hackintosh, had the same issue, took me weeks to fix it, in the end I had to I downgrade the USB drivers in the bios to accommedate the TI2's needs. (TI2 was struggling to connect to USB3.0 ports, it wanted old school 2.0 connection) PS. I dont want to do that again.


    Marc or anyone else qualified, Is there anything you could suggest me trying on my new system to get the integration working ?


    I need my baby back.


    Joe Hertz;(

  • Work perfect with Mojave 10.14.6, MacBook Pro (USB-C) and iMac 2014.

    Virus TI2

    +

    Analog Rytm MKII

    Maschine MKII

    Kontrol X1

    Drumbrute

    Minibrute 2S

    Modular synth (Eurorack)

    Novation Zero MKII

    Nord Modular G2 and Micromodular.

    ---

    RME Fireface with ADAT Alesis.


  • Please let us know what USB Hubs you use and how your devices are connected.

    Bass Player and Synthesist.
    Virus TI2 Darkstar | Virus TI2 Desktop | Moog Sub 37 | Blofeld | Machinedrum | Monomachine | Analog Four | Digitone | MPC Live | NI Maschine+
    Mac OS X 10.14.6 (Mojave) | Cubase Pro 11.0 | Ableton Live 9.6 | Logic 10.4 | MainStage 3.4 | NI Komplete 12 | RME Fireface UFX+